Jump to content

Back to dayzgame.com
Photo

X3DAudio1_6.dll is missing from your computer


7 replies to this topic

#1 Oscar Eustace

Oscar Eustace

    On the Coast

  • Members
  • Pip
  • 2 posts

Posted 03 September 2012 - 09:25 PM

I have a problem when trying to join a server. My friend who bought it at the same time has the same problem


*Which version of the game did you purchase? STEAM or RETAIL or MIXED: Steam



*Are you running an Arma 2 OA beta patch? If so what version?: Not sure purchased today, newest version i would imagine



*Which method are you using to launch the game? I.E Sixupdater/steam/batch file: SixUpdater



*What is the Error/Problem you're having? Please provide screenshots if possible:

Attached File  Problem.png   572.36KB   13 downloads

^^ when i try and join a server this comes up.

*Your PC specs:

Not sure, and dont think its relevant to this problem

*Your Operating System:
Windows7


*Have you looked at these threads?:
Did a search for the problem and found nothing

Cheers guys,

#2 tomfin

tomfin

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 77 posts

Posted 03 September 2012 - 09:32 PM

I've been trying to help out a guy with a similar error.

Try reinstalling DirectX. Right-click and run the installer as an Administrator.

#3 Oscar Eustace

Oscar Eustace

    On the Coast

  • Members
  • Pip
  • 2 posts

Posted 03 September 2012 - 09:38 PM

Yeah, i downloaded Directx from http://www.microsoft...ls.aspx?id=8109

All works, game loads,but now i get a message saying " Bad serial number given in setup"

#4 AmberHelios

AmberHelios

    Bean King

  • DayZ Community Support
  • PipPipPipPipPipPip
  • 2288 posts
  • LocationMold, Wales

Posted 03 September 2012 - 09:38 PM

re install direct x the x3daudio is part of the package it was a common problem with the demo if you got it from steam the redist should be in the arma folders

also did you run each game from steam under admin first before using 6networks

hope this helps

#5 AmberHelios

AmberHelios

    Bean King

  • DayZ Community Support
  • PipPipPipPipPipPip
  • 2288 posts
  • LocationMold, Wales

Posted 03 September 2012 - 09:40 PM

you need to run steam in admin mode right click and run as admin and launch the games though steam then it should be fine
  • tomfin gave their beans

#6 Delta Smoke 01

Delta Smoke 01

    Bean King

  • DayZ Forum Team
  • PipPipPipPipPipPip
  • 1090 posts
  • LocationLancashire UK

Posted 03 September 2012 - 09:46 PM

I got both these issues when i got a new pc setup and copyed the already installed game from my old hdd to my new ssd hard drive. Install the latest direct x and re install the game.

#7 Sgt.Asshat

Sgt.Asshat

    Bean King

  • Banned
  • PipPipPipPipPipPip
  • 1184 posts

Posted 03 September 2012 - 09:47 PM

Yeah, i downloaded Directx from http://www.microsoft...ls.aspx?id=8109

All works, game loads,but now i get a message saying " Bad serial number given in setup"


Run arma 2 then OA to menu then you're good to go :P

#8 tomfin

tomfin

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 77 posts

Posted 03 September 2012 - 09:49 PM

AmberHelios is correct, you have to run Steam as an admin one time, launch each game once, then your CD keys should be validated and written to the registry correctly.

Thanks for posting back that installing DirectX solved your XAudio DLL crash. Happy hunting :)