Jump to content

Back to dayzgame.com
Photo

BattlEye re installation, MISSING STRING


10 replies to this topic

#1 xSyndicate

xSyndicate

    On the Coast

  • Members
  • Pip
  • 2 posts

Posted 27 July 2012 - 08:14 PM

Ok so I was getting some loading problems on servers(getting stuck at loading) so I was going to try and re-install battleye through steam but when I press "Re-install BattlEye anti-cheat" I get a error saying MISSING STRING. I am currently on 1.7.2.4 and the latest beta patch. I tried manually installing battleye through the website but that didn't work either, tried uninstalling and reinstalling through BESetup, same issue. I managed to get into a server and everything is working fine but it still bothers me that whenever I try reinstalling battleye through steam I get a MISSING STRING error and it could be the reason why I get stuck at loading a lot.
  • Lettuce gave their beans

#2 Mattolio

Mattolio

    Woodland Warrior

  • Members
  • PipPipPip
  • 36 posts

Posted 27 July 2012 - 08:32 PM

I am having this issue also. Just got kicked with a battle eye failed to update message. Thought i'd try re-installing battle eye through steam but I get 2 missing string errors. Nothing I've tried so far seems to fix it.

Edited by Mattolio, 27 July 2012 - 08:34 PM.

  • Lettuce gave their beans

#3 BulletPROZ

BulletPROZ

    Woodland Warrior

  • Members
  • PipPipPip
  • 30 posts

Posted 27 July 2012 - 08:43 PM

I HAVE SAME PROBLEM .... OMG!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!..... :(
  • Lettuce gave their beans

#4 xSyndicate

xSyndicate

    On the Coast

  • Members
  • Pip
  • 2 posts

Posted 27 July 2012 - 08:59 PM

Yep, I have tried to do everything that I found through google and forums but nothing seems to work.
  • Lettuce gave their beans

#5 Mattolio

Mattolio

    Woodland Warrior

  • Members
  • PipPipPip
  • 36 posts

Posted 27 July 2012 - 09:24 PM

Also tried replacing the be dll's (http://www.battleye.com/download.html) and overwriting the ones at: C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\Expansion\BattlEye (both the client and server dll's).

Doesn't solve the issue. Going to uninstall be and see if it will then reinstall without error.

Well that didn't work - I believe it may be that, the server side battleeye files require updating?

Edited by Mattolio, 27 July 2012 - 09:32 PM.

  • Lettuce gave their beans

#6 Demijebus

Demijebus

    On the Coast

  • Members
  • Pip
  • 1 posts

Posted 27 July 2012 - 09:48 PM

Hey everyone,
I was having the same problem linked with a kicking from every server i tried to join. In an attempt to solve the problem i went to re-install battleye and received the Missing String error. I wasn't able to solve the Missing String error but I did fix the Kick issue.

1 - open steam, right click arma2 OA, go to properties, local files, verify integrity of game cache ( it should find at least a couple errors and auto fix)
2 - open six updater and do a install, update mod and launch.

As far as the Missing string error i suggest a manual install of the newest version of Battleye direct from www.battleye.com/download.html

Hope this helps, i'm choosing to ignore the String error seeing as how i know i have the newest version manually installed.
  • Vestia and Lettuce gave their beans

#7 HadesWarpig

HadesWarpig

    Scavenger

  • Members
  • PipPip
  • 18 posts
  • LocationUpstate NY

Posted 27 July 2012 - 09:52 PM

Same issue here, nothing I have tried has worked to fix this.
  • Lettuce gave their beans

#8 magikalcoffee

magikalcoffee

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 52 posts

Posted 27 July 2012 - 10:18 PM

Hey everyone,
I was having the same problem linked with a kicking from every server i tried to join. In an attempt to solve the problem i went to re-install battleye and received the Missing String error. I wasn't able to solve the Missing String error but I did fix the Kick issue.

1 - open steam, right click arma2 OA, go to properties, local files, verify integrity of game cache ( it should find at least a couple errors and auto fix)
2 - open six updater and do a install, update mod and launch.

As far as the Missing string error i suggest a manual install of the newest version of Battleye direct from www.battleye.com/download.html

Hope this helps, i'm choosing to ignore the String error seeing as how i know i have the newest version manually installed.



this works just done it and im re-installing now thanks dude
  • Lettuce gave their beans

#9 Mattolio

Mattolio

    Woodland Warrior

  • Members
  • PipPipPip
  • 36 posts

Posted 27 July 2012 - 10:32 PM

I didnt have to do anything - just got a successful update of be in-game and all seems ok.
  • vladimpales and Lettuce gave their beans

#10 Ingodet

Ingodet

    On the Coast

  • Members
  • Pip
  • 4 posts

Posted 04 August 2012 - 08:33 AM

So i tried:

Validating game cache
Manual download of Battleeye
Redownloaded both latest arma 2 patch and latest DayZ
Just "be in-game" but I didnt get any updates of any sort

Still getting kicked from every server. Am I doomed to a full reinstall?

Edit: Looks like this. The kick occurs when I try to enter a server, any server.
http://cloud.steampo...82ECBD72ACB12E/

Edited by Ingodet, 04 August 2012 - 11:13 AM.

  • Lettuce gave their beans

#11 Lettuce

Lettuce

    On the Coast

  • Members
  • Pip
  • 4 posts

Posted 13 August 2014 - 01:59 AM

Uninstall all Arma 2 and ArrowHead extension if installed by CD or bought from retail shop etc. Then load up steam as Steam has taken over Gamespy as host for Arma 2 and Dayz Commander etc. Then add the game in Steam by activate a product on steam, and then by using the CD version key code normally located on back of manual booklet given in case, it wil then automatically install Aram2... Do the same with ArrowHead key code and it will install all updated as well...  After installing Arma 2 and ArrowHead through steam, go to library then right click on Arma 2 scroll down to properties and click that...  Click on Local files tab and then click on verify integrity of game cache for both version to fully check installation. Then run both games once to fully activate and complete installation of extras like Directx files. After that search all Dayz Commander files through explorer except @dayz map server or @dayz overwatch etc. Move them to a folder separate that you can find later to recopy back to Dayz new install. Then delete all remaining that has been searched using explore search bar with Dayz as the word search item etc. Go to uninstall utility and uninstall Dayz from system... Then go to this link http://www.dayzcommander.com/#download and re- download and install Dayz Commander New Version. Then find where the @dayz Overwatch file go, for server locating to save re downloading them through Dayz Commander. The Battle eye issue I've so far gone in steam to library then right click on Arma 2 scroll down to properties and click that...  Click on Local files tab, then Browse local files click on that... Open up folder BEsetup folder, then (Setup_BattlEyeARMA2OA) file, I right clicked and run as Administrator to install Battleye. It's mostly found in the Expansion folder, there I also went to http://www.battleye.com/download.html to add a extra BEClient.dll file to the Battleye folder inside expansion folder.. Did this process for both ArrowHead and Arma2 and added BEClient.dll to both battleye folder after running the setup as well for both state above. Still to find out if this has all work :P ... But it as far as I've got .. (Seems to be working so far apart from being kicked to menu once I'm reached to Lobby of sever etc I found this from another post, hopefully it helps me...  ( Yay finally got it working)   After also following the quote procedure, I also went into the steam to the library section and then right click on Arma 2 scroll down to properties and click that...  Click on Local files tab, then Browse local files click on that, look for both arma2.exe and ArmA2OA.exe and in properties go to the compatablity section, and click the run as administration box, to have it ticked..   It's all working now for me...   

I submitted a ticket and this worked for me:


A recent update of ARMA2 Operation Arrowhead my have been applied incorrectly.

If you are using Steam, your game was automatically updated as part of the Stream update process. It is possible that the update process may have corrupted one or more files. To repair this, do the following.

* Close down steam, and start it as administrator. To do so, find Steam in your start menu, right-click on the shortcut and select Run as Administrator.
* Go to your game library and locate ARMA2. Right-click on the game and select "Properties". Click on the "Local Files" tab. Click on "Verify integrity of game cache". This process may take a bit of time as Steam verifies your game files.
* Once this is done, do the same for ARMA2 Operation Arrowhead.
* Launch ARMA2 and then close/exit the game. This is to ensure that Steam finishes any installation or reconfiguration.
* Launch ARMA2 Operation Arrowhead and close it.
* If you use Six Updater, launch Six Updater and optionally update the mod to the latest version. If you're using other means of launching DayZ, update or launch the mod accordingly.


Edited by Lettuce, 14 August 2014 - 08:17 AM.