Jump to content

Back to dayzgame.com
Photo

How to fix Battleye Errors!


21 replies to this topic

#1 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 02:56 AM

Hey guys I thought I'd make a TuT on how to fix battleye errors ( Battleye failed to update, initialization failed, etc ).

1. Update the dll. files in both Arma 2 and Arma 2 OP in the steam file. Remember the dll. files are located in the expansion folder in OP folder.

2. Important step : Start > Type %Appdata% > Local > Arma 2 OA > Battleye and paste both updated dll. files in that folder. Once you do that all the error's should go away and everything should be work fine. At least for me it did. So go head and give it a try!

Here is what it looks like > Posted Image


All the updated dll. files can be found here > http://www.battleye.com/download.html


*REMEMBER THIS WILL ONLY FIX COMMON ERRORS*

Edited by raman599, 22 July 2012 - 03:58 AM.

  • Sebax, gregster713 and AGuyYouDunno gave their beans

#2 OnyxGunslinger

OnyxGunslinger

    On the Coast

  • Members
  • Pip
  • 2 posts

Posted 22 July 2012 - 02:57 AM

Which file do we download? v1.61.94945+?




#3 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 03:00 AM

Which file do we download? v1.61.94945+?


If you are on 94945 beta patch or above, choose the v1.61.94945+. If not choose the other.

#4 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 03:38 AM

after i go to local i cant find arma2oa. how do i get it in my local folder ?

#5 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 03:41 AM

wait do i make a arma2oa folder? and i cant seem to download battleye again unless i delete my beta folder and my battleeye folder from my expansion folder and re download the latest patch. when i do that, it automatically puts battleye bak in my expansion folder.

#6 COGTHEUNDEAD

COGTHEUNDEAD

    Woodland Warrior

  • Members
  • PipPipPip
  • 37 posts

Posted 22 July 2012 - 03:42 AM

Hey guys I thought I'd make a TuT on how to fix battleye errors ( Battleye failed to update, initialization failed, etc ).

1. Update the dll. files in both Arma 2 and Arma 2 OP in the steam file. Remember the dll. files are located in the expansion folder in OP folder.

2. Important step : Start > Type %Appdata% > Local > Arma 2 OA and paste both updated dll. files in that folder. Once you do that all the error's should go away and everything should be work fine. At least for me it did. So go head and give it a try!


All the updated dll. files can be found here > http://www.battleye.com/download.html


*REMEMBER THIS WILL ONLY FIX COMMON ERRORS*


thanks
im running xp and its
name of drive containing windows:\Documents and Settings\name of computer \Local Settings\Application Data\ArmA 2
OA\BattlEye

at least that was it for me
lets see if its works

#7 Sebax

Sebax

    On the Coast

  • Members
  • Pip
  • 5 posts

Posted 22 July 2012 - 03:44 AM

This should be the path the the folder:

C:\Users\<Your Username>\AppData\Local\ArmA 2 OA

Also, how can I check what Beta Build I have so I can see what file I must download?

#8 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 03:47 AM

wait guys i jusst take out the dll from the battle eye folder rite? im putting the hole battleye folder in my local/arma2oa. is that rong?

#9 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 03:47 AM

This should be the path the the folder:

C:\Users\<Your Username>\AppData\Local\ArmA 2 OA

Also, how can I check what Beta Build I have so I can see what file I must download?


at the main menu look at the bottom right.

#10 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 03:48 AM

after i go to local i cant find arma2oa. how do i get it in my local folder ?


it should already be there.

#11 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 03:48 AM

http://prntscr.com/chiel is this it ? please help me

#12 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 03:48 AM

wait guys i jusst take out the dll from the battle eye folder rite? im putting the hole battleye folder in my local/arma2oa. is that rong?


just put the dll. files in there. nothing else. make sure there up 2 date.

#13 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 03:49 AM

http://prntscr.com/chiel is this it ? please help me


yes thats it. run the game now.

#14 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 03:50 AM

ok ill try it rite now. thanks and wish me gl ^_^

#15 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 03:54 AM

didnt work :( launched six launched and it kiiked me out

#16 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 03:58 AM

didnt work :( launched six launched and it kiiked me out


forgot to say u got to put in the battleye folder.

#17 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 03:59 AM

http://prntscr.com/chivj this is wha happened

#18 JoshWantsDayZ

JoshWantsDayZ

    Scavenger

  • Members
  • PipPip
  • 28 posts

Posted 22 July 2012 - 04:00 AM

oh i have a battleye folder in my expansion and im suppose to put the dll in a battleye folder?

#19 Sebax

Sebax

    On the Coast

  • Members
  • Pip
  • 5 posts

Posted 22 July 2012 - 04:05 AM

I think this fixed my problems or I joined a server that doesn't require Battleye...

#20 raman599

raman599

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 57 posts

Posted 22 July 2012 - 04:10 AM

http://prntscr.com/chivj this is wha happened


did you make sure you updated the dll. files in the steam folder also?