Jump to content

Back to dayzgame.com
Photo

Battleye initialization failed - Fix?

Battleye

  • Please log in to reply
27 replies to this topic

#1 2410jero

2410jero

    On the Coast

  • Members
  • Pip
  • 4 posts

Posted 18 July 2012 - 10:42 PM

I got "Battleye initialization failed" every time i tried to join a server, and it looks like many have the same problem.

What I did was update my Six Launcer and now it works fine.

Hope it helps.

-Rolf
  • Tobeh gave their beans

#2 Flexho

Flexho

    Survivor

  • Members
  • PipPipPipPipPip
  • 236 posts
  • LocationDenmark

Posted 18 July 2012 - 10:45 PM

Other topics has been made about this a few hours ago. Think the latest Six Updater - update is causing this problem with battleye not letting people connect to Host.
+1 for fix soon. :)

#3 MWALKERWORLD

MWALKERWORLD

    Scavenger

  • Members
  • PipPip
  • 25 posts

Posted 18 July 2012 - 10:46 PM

After I updated My 6 launcher It gave me this error

#4 w00p

w00p

    On the Coast

  • Members
  • Pip
  • 1 posts

Posted 19 July 2012 - 12:05 AM

Same problem here after I updated Six Launcher

Edited by w00p, 19 July 2012 - 12:07 AM.


#5 melted349

melted349

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 81 posts
  • LocationUnited States - Kansas

Posted 19 July 2012 - 02:04 AM

Had the same problem, using Six Launcher and tried with Dayz Commander. Tried manually updating the .dll files for Battleye, still didn't work. Found out that in my case I also had a copy of the .dll in my AppData directory (Win7) that needed to be replaced. Hope this helps others.
1 of 3 Admins to US 863 Kansas City
My Status: I shoot other players on sight unless: 1: I know you 2: You're in my mumble server 3: We've spoke in game
*Disclaimer: Still doesn't mean I won't shoot you. I assume other players as hostile until proven otherwise.

#6 thefonz

thefonz

    Survivor

  • Members
  • PipPipPipPipPip
  • 240 posts

Posted 19 July 2012 - 03:57 AM

Had the same problem, using Six Launcher and tried with Dayz Commander. Tried manually updating the .dll files for Battleye, still didn't work. Found out that in my case I also had a copy of the .dll in my AppData directory (Win7) that needed to be replaced. Hope this helps others.


I forget the general location of that directory, mind helping?
ING: thefonz
Appearence: Ghillie
Primary: M14
Secondary: G17
Playstyle: Cautiously Friendly

I'll happliy help you, but give me a reason and I'll happily kill you too.

#7 Arims

Arims

    Scavenger

  • Members
  • PipPip
  • 27 posts

Posted 19 July 2012 - 04:05 AM

Today I just updated six launcher for dayz and now I cant go into any servers cuz of this error....=(

#8 LivingError

LivingError

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 51 posts

Posted 19 July 2012 - 04:56 AM

I forget the general location of that directory, mind helping?


Here are the two directories he is referring too:

[Steam Install 64-Bit Machine]

C:\Program Files (x86)\Steam\steamapps\common\arma 2 operation arrowhead\Expansion\BattlEye

[Steam Install 32-Bit Machine]

C:\Program Files\Steam\steamapps\common\arma 2 operation arrowhead\Expansion\BattlEye


[AppData - You will need to view hidden files and folders]

%USERPROFILE%\AppData\Local\ArmA 2 OA\BattlEye


Edited by LivingError, 19 July 2012 - 05:13 PM.

  • thefonz and Aqutic gave their beans

Check these threads for fixes to the most common DayZ errors.

http://dayzmod.com/f...beta-patch-fix/
http://dayzmod.com/f...24-error-fixes/


#9 Uncle Gus

Uncle Gus

    Survivor

  • Members
  • PipPipPipPipPip
  • 117 posts

Posted 19 July 2012 - 08:51 AM

Nothing mentioned by anybody in any thread has worked for me so far. I was posting earlier from my work computer. The last time I played DayZ at work, I got some kind of session time out error message and got kicked. My workmate across the room got the same error at the same time, but we were on the same server, so it's had to say where the error originated. I am now at home and I have run the Six launcher, which updated itself, then the Beta expansion and I can log in to DayZ servers no worries. So I'm wondering if the error I had at work had something to do with anything.

Tomorrow I will try the good old turn it off and on again on my work PC to see what that addresses. After that, I guess I won't be playing DayZ in my lunch breaks for the foreseeable future :/

#10 Uncle Gus

Uncle Gus

    Survivor

  • Members
  • PipPipPipPipPip
  • 117 posts

Posted 19 July 2012 - 09:26 AM

Hmmm, strangely enough I am now getting kicked by BattlEye for "idling too long in the lobby." Once was before I had even joined the lobby, and just now after playing INGAME for about fifteen minutes. Curse you, BattlEye.

#11 Pr0zzK1D

Pr0zzK1D

    Woodland Warrior

  • Members
  • PipPipPip
  • 30 posts
  • LocationThe Netherlands

Posted 19 July 2012 - 09:44 AM

I had this problem too, after getting the Six Launcher update. I simply fixed it by downloading another BattlEye Server.dll and Client.dll . You can find the files here: http://www.battleye....ml<br /><br />HOW TO INSTALL:

1. Download the Server.dll and the Client.dll (32-bit) v1.11 / v1.60 / v1.61.94876
2. Go to your ArmA2 BattlEye installation folder (C://ProgramFiles(x86)/Steam/Steamapps/Common/ArmA2/BattlEye)
3. OPTIONAL: Make a backup of the Server.dll and the Client.dll
4. Place the downloaded files in there and overwrite them.

5. Download the Server.dll and the Client.dll (32-bit) v1.61.94945+
6. Go to your ArmA2 OA BattlEye installation folder (C://ProgramFiles(x86)/Steam/Steamapps/Common/ArmA2 Operation Arrowhead/Expansions/beta/BattlEye)
7. OPTIONAL: Make a backup of the Server.dll and the Client.dll
8. Place the downloaded files in there and overwrite them.

Hope this helped you, atleast it worked for me.
  • Askeladd, Paltos, Uncle Gus and 3 others gave their beans

#12 datguy

datguy

    Survivor

  • Members
  • PipPipPipPipPip
  • 127 posts

Posted 19 July 2012 - 11:15 AM

fucking six launcher. piece of shit. thanks for breaking my game, asshole.

#13 Smuffins

Smuffins

    On the Coast

  • Members
  • Pip
  • 2 posts

Posted 19 July 2012 - 02:09 PM

Do I just copy and paste the files, or does it require some other process of placing the files??


#14 Pr0zzK1D

Pr0zzK1D

    Woodland Warrior

  • Members
  • PipPipPip
  • 30 posts
  • LocationThe Netherlands

Posted 19 July 2012 - 03:34 PM

@Smuffins

Copy / Pasting is fine, just dragging the files in there could be done also! As long as you place it in the good map, just as told above.

#15 subluminal

subluminal

    On the Coast

  • Members
  • Pip
  • 9 posts

Posted 19 July 2012 - 03:55 PM

I had this problem too, after getting the Six Launcher update. I simply fixed it by downloading another BattlEye Server.dll and Client.dll . You can find the files here: http://www.battleye......<br /><br />HOW TO INSTALL:

1. Download the Server.dll and the Client.dll (32-bit) v1.11 / v1.60 / v1.61.94876
2. Go to your ArmA2 BattlEye installation folder (C://ProgramFiles(x86)/Steam/Steamapps/Common/ArmA2/BattlEye)
3. OPTIONAL: Make a backup of the Server.dll and the Client.dll
4. Place the downloaded files in there and overwrite them.

5. Download the Server.dll and the Client.dll (32-bit) v1.61.94945+
6. Go to your ArmA2 OA BattlEye installation folder (C://ProgramFiles(x86)/Steam/Steamapps/Common/ArmA2 Operation Arrowhead/Expansions/beta/BattlEye)
7. OPTIONAL: Make a backup of the Server.dll and the Client.dll
8. Place the downloaded files in there and overwrite them.

Hope this helped you, atleast it worked for me.


This fixed the battleeye problem for me aswell. Thanks

Edit: One problem fixed, and a new one has arisen, im now stuck at "recieving data" and im getting bumped out of the server after a while.
New Edit: Forget the last problem, i fixed that by disconnection from my VPN.

Edited by subluminal, 19 July 2012 - 04:26 PM.


#16 Smuffins

Smuffins

    On the Coast

  • Members
  • Pip
  • 2 posts

Posted 19 July 2012 - 04:29 PM

It seems that when i go into the Arma2 Files the BattleEye folder isn't there so I can't put the files into it.

Edited by Smuffins, 19 July 2012 - 04:30 PM.


#17 nathkrul

nathkrul

    Woodland Warrior

  • Members
  • PipPipPip
  • 30 posts
  • LocationUK

Posted 19 July 2012 - 04:50 PM

Thanks m8, already dloaded the files but didnt realise i needed the other 2 older files in the other folder, thanks , youre a great help :)

#18 Pr0zzK1D

Pr0zzK1D

    Woodland Warrior

  • Members
  • PipPipPip
  • 30 posts
  • LocationThe Netherlands

Posted 19 July 2012 - 05:06 PM

@Smuffins

Do you have a BEsetup map inside your ArmA2 folder? if so, open it and run it. After that the map is supposed to appear (This worked for my friend, when he had to update it). If this isn't the case, try going to your Steam and open the Games menu. In the Games menu, right-click on ArmA2 and choose Re-Install (or Install) BattlEye. If the map still doesn't appear, then i dont know how to fix it, sorry for that. But im almost sure it wil work!

@Nathkrul

No problem, im hoping it works for you (altough im pretty sure it will work)!

#19 XOR

XOR

    On the Coast

  • Members
  • Pip
  • 9 posts
  • LocationPrigorodky

Posted 19 July 2012 - 05:12 PM

I had this problem too, after getting the Six Launcher update. I simply fixed it by downloading another BattlEye Server.dll and Client.dll . You can find the files here: http://www.battleye......<br /><br />HOW TO INSTALL:

Hope this helped you, atleast it worked for me.


Tried this but BattlEye fails init still for me

#20 LivingError

LivingError

    Helicopter Hunter

  • Members
  • PipPipPipPip
  • 51 posts

Posted 19 July 2012 - 05:26 PM

Tried this but BattlEye fails init still for me


Trying checking out the two links in my signature, especially the first one.

Check these threads for fixes to the most common DayZ errors.

http://dayzmod.com/f...beta-patch-fix/
http://dayzmod.com/f...24-error-fixes/






Also tagged with one or more of these keywords: Battleye