Jump to content

Back to dayzgame.com
Photo

Arma 2 oa has stopped working - crash to desktop: FIXED!!

crash windows stopped working arma 2 oa has stopped working crash to desktop desktop fix fixed

  • Please log in to reply
123 replies to this topic

#1 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 12:42 PM

Many of my friends, and a lot of other people on the forums have been having this issue, when you go to join a game and once it gets passed the tank loading screen it crashes. I tried for about 4 hours to fix this, as many different ways I possibly could. I finally found a solution.

First: Navigate to your "arma 2 operation arrowhead/Expansion/BattlEye" folder. Following this, run the uninstall.exe
Now the folder should be deleted. Go back to the "Expansion" folder and delete the "beta" folder.
once this is done, go to your arma 2 folder and uninstall BattlEye here too. This is found in arma 2/BattlEye.

Once you have deleted your beta folder and uninstalled both BattlEye's in arma 2 and arma 2 operation arrowhead, download the latest beta patch (however I think it's a little shifty at the moment, so 94876 will do). Now run the Beta .exe and it should stop at 3% and ask you to install BattleEye - do so. Once BattleEye is installed, complete the installation of the beta patch and you're ready to go!

Good luck!

**EDIT**

Go to your arma 2 oa folder > open Expansion > open BattlEye and run the uninstall.exe
Go to your arma 2 folder > open BattlEye and run the uninstall.exe (if it isn't there, don't worry about it)
Run the game with (the beta should still be installed - doesn't matter what one)
Try to join a server - you should get stuck at either Loading or Wait for Host - this is normal
Close the game and go back into your arma 2 oa folder > Expansion and delete the beta.
Download and install beta patch 94700
It will ask you to install BattleEye, do so.
Go into your arma 2 folder > go into BEsetup and run the .exe
Go back into your arma 2 oa folder > Expansion> beta and copy the BattleEye folder (DO NOT CUT OR DELETE IT - YOU ARE MAKING TWO COPY'S OF IT).
Paste the BattleEye folder in the main arma 2 oa directory.
Open arma 2 oa and join a NORMAL arma game. Any will do, as long as it is NOT DayZ and it has BattlEye active.
Once in, abort and close the game.
Download and install beta patch 94876 and install it.
Open arma 2 oa and join a DayZ game.

Edited by Rammfisch, 14 July 2012 - 04:34 PM.

  • ricky, Kebab, MajesticShitstain and 16 others gave their beans
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#2 b00m666

b00m666

    Survivor

  • Members
  • PipPipPipPipPip
  • 192 posts
  • LocationThe Netherlands

Posted 14 July 2012 - 12:51 PM

Maybe a download link to the patch please>?

Found one: http://forums.bistud...(1-61-MP-build)


Edit: didn't work.

Edited by b00m666, 14 July 2012 - 12:58 PM.


#3 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 12:58 PM

Now me and 2 friends, who all did the same thing to cock it up in the first place are the only ones who tested this, so don't sue me if it doesn't work XD But I'm trying my hardest.
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#4 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 01:18 PM

Also, if this happens again, or if you cannot find your BattleEye folder in the arma 2 folder, go into steam > right click on Arma 2 > click Properties > Click Local Files and then click Verify Integrity of Game Cache.
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#5 b00m666

b00m666

    Survivor

  • Members
  • PipPipPipPipPip
  • 192 posts
  • LocationThe Netherlands

Posted 14 July 2012 - 01:23 PM

Rammfisch, do you and your friends use six launcher for this? Or manual? if manual, how the fuck do you update Combined operations to 1.61

#6 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 01:27 PM

Rammfisch, do you and your friends use six launcher for this? Or manual? if manual, how the fuck do you update Combined operations to 1.61

This is manual. I have never used Six Updater. Firsto of all, do you have the beta installed? I assume so, but which one? If it's 94700 or below, that is 1.60 94876 and above is 1.61
Download them here: http://www.arma2.com/beta-patch.php/ then just run the .exe
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#7 b00m666

b00m666

    Survivor

  • Members
  • PipPipPipPipPip
  • 192 posts
  • LocationThe Netherlands

Posted 14 July 2012 - 02:11 PM

I installed 94876, im reinstlaling arma atm

#8 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 02:23 PM

add seeyouentea on skype if you need help
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#9 b00m666

b00m666

    Survivor

  • Members
  • PipPipPipPipPip
  • 192 posts
  • LocationThe Netherlands

Posted 14 July 2012 - 02:26 PM

I runned the updater but when i start combined operations it says im still at patch 1.60.87580. How do i update combined operations.

#10 b00m666

b00m666

    Survivor

  • Members
  • PipPipPipPipPip
  • 192 posts
  • LocationThe Netherlands

Posted 14 July 2012 - 02:28 PM

Also, i can't find your name in skype. Add b00m667

#11 b00m666

b00m666

    Survivor

  • Members
  • PipPipPipPipPip
  • 192 posts
  • LocationThe Netherlands

Posted 14 July 2012 - 02:36 PM

I clicked the beta patch shortcut to start operations, now im not stuck at host, now im crashing again.

#12 Jean Jacques Serrault

Jean Jacques Serrault

    Survivor

  • Members
  • PipPipPipPipPip
  • 261 posts
  • LocationSomewhere on my beloved earth.

Posted 14 July 2012 - 02:47 PM

Things are still no good for me after having done your steps above. Perhaps other people would have better luck than me. :)
A guide to install Day Z, beta patches, and fixing some errors:

http://dayzmod.com/f...beta-patch-fix/

#13 aimosal

aimosal

    On the Coast

  • Members
  • Pip
  • 3 posts

Posted 14 July 2012 - 03:04 PM

Nah, I'm still getting this problem despite trying the fix.

#14 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 03:24 PM

THIS HAS BEEN ADDED TO THE TOP OF THE THREAD

Ok, here's what to do now. in steps:

Go to your arma 2 oa folder > open Expansion > open BattlEye and run the uninstall.exe
Go to your arma 2 folder > open BattlEye and run the uninstall.exe (if it isn't there, don't worry about it)
Run the game with (the beta should still be installed - doesn't matter what one)
Try to join a server - you should get stuck at either Loading or Wait for Host - this is normal
Close the game and go back into your arma 2 oa folder > Expansion and delete the beta.
Download and install beta patch 94700
It will ask you to install BattleEye, do so.
Go into your arma 2 folder > go into BEsetup and run the .exe
Go back into your arma 2 oa folder > Expansion> beta and copy the BattleEye folder (DO NOT CUT OR DELETE IT - YOU ARE MAKING TWO COPY'S OF IT).
Paste the BattleEye folder in the main arma 2 oa directory.
Open arma 2 oa and join a NORMAL arma game. Any will do, as long as it is NOT DayZ and it has BattlEye active.
Once in, abort and close the game.
Download and install beta patch 94876 and install it.
Open arma 2 oa and join a DayZ game.

This SHOULD work. Try it, if it doesn't I'll see what I can do. This will work best with people NOT using six launcher. Not sure if It works with six launcher - but it does regularly.

Edited by Rammfisch, 14 July 2012 - 04:35 PM.

Posted Image
Host/Admin of US 828 Admin of Dallas 350

#15 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 03:43 PM

Confirmed working with Six Updater/Launcher for those who use it.
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#16 aimosal

aimosal

    On the Coast

  • Members
  • Pip
  • 3 posts

Posted 14 July 2012 - 04:01 PM

Following instructions now, though came across a problem:

- Cannot install beta patch 94700 because I'm using the 1.61 version and they aren't compatible.

I just used the 94876 beta patch instead and went from there. I'm on the step where I need to join a normal ARMA game and will post with results when I've finished all the steps.

--

All done and it worked. Thanks for the help!

Edited by aimosal, 14 July 2012 - 04:11 PM.


#17 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 04:19 PM

Following instructions now, though came across a problem:

- Cannot install beta patch 94700 because I'm using the 1.61 version and they aren't compatible.

I just used the 94876 beta patch instead and went from there. I'm on the step where I need to join a normal ARMA game and will post with results when I've finished all the steps.

--

All done and it worked. Thanks for the help!


No problem :) Spent a few hours putting it all together and fixing error after error XD Good to see it did some good. Would be nice if it could be pinned so others could see it, but I doubt that'll happen :P
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#18 memske

memske

    On the Coast

  • Members
  • Pip
  • 3 posts

Posted 14 July 2012 - 04:40 PM

Mine still crashes after doing this :(

#19 Rammfisch

Rammfisch

    Emperor of the Universe

  • Members
  • PipPipPipPipPipPip
  • 556 posts
  • LocationNOL-M9, Null-sec

Posted 14 July 2012 - 04:42 PM

Mine still crashes after doing this :(

When does it crash? Is it once you join the server and the loading with the tank screen is done and then it crashes? Because if so, my method should 100% work. Just make sure you follow each step properly. If you're not sure of a step, just ask.
Posted Image
Host/Admin of US 828 Admin of Dallas 350

#20 Spiritreader

Spiritreader

    Scavenger

  • Members
  • PipPip
  • 10 posts
  • LocationGER

Posted 14 July 2012 - 04:47 PM

Hi Rammfisch!

Thank you so much. It was THE solution working. I really thought i will get crazy because i didn't manage to get it working.

Edit: If it isnt working for you (i got the steam version) Additional i think you have to remove a battleye file located in User\Appda\Local\Arma2\BattlEye
I cannot really confirm it, but what i can confirm that the file i deleted was 100kb and the new one created after using Rammfisch's fix was 93kb. So if it does not work for you try it out

(Sorry english is not my native language ^_^)

Have a nice day!
Spirtreader

:D

Edited by Spiritreader, 14 July 2012 - 04:52 PM.






Also tagged with one or more of these keywords: crash, windows, stopped, working, arma 2 oa has stopped working, crash to desktop, desktop, fix, fixed